Camelia, the Perl 6 bug

IRC log for #deepin, 2016-09-23

| Channels | #deepin index | Today | | Search | Google Search | Plain-Text | summary

All times shown according to UTC.

Time Nick Message
00:53 sbw joined #deepin
02:14 hualet_deepin joined #deepin
02:48 JLye joined #deepin
04:05 liuhuanjie_ joined #deepin
07:32 OT_iux joined #deepin
07:34 OT_iux Hi, I git cloned deepin-terminal, I wonder if I have to build Deepin-ui from github before start to run the ./src/main.py of deepin-terminal ?
08:00 felixonmars OT_iux: please try to clone it from manateelazycat's repo
08:01 OT_iux felixonmars, thank you
08:01 felixonmars the old version that depends on deepin-ui is obsolete now
08:01 OT_iux oh
08:01 felixonmars the new one is using vte3 and vala
08:01 OT_iux i c, thank you very much
08:01 felixonmars yw :)
09:02 OT_iux hmm, I cloned it from manateelazycat's repo, and installed all the dependencies. (i'm using Ubuntu 16.04)
09:02 OT_iux when make && ./main
09:03 OT_iux there is Error: ./deepin-terminal/lib/utils.vala.c:1424:2: error: unknown type name ‘GdkSeat’
09:04 deepin-bot [felixonmars]:  you might still need something else
09:04 OT_iux hmm, deepin-menu ?
09:04 OT_iux or something like python-gtk-deepin ?
09:05 deepin-bot [somebody]:  Need gtk3 version more than 3.19
09:05 deepin-bot [felixonmars]:  no, no more python :)
09:06 OT_iux thank you... I'll try install libgtk3 in ubuntu official source
09:07 OT_iux hmm there are only libgtk3.0-cil-dev (2.99.3-2) in apt
09:09 OT_iux I use this command in README.md to install dependencies: sudo apt-get install valac libgtk-3-dev libgee-0.8-dev libvte-2.91-dev libjson-glib-dev libsecret-1-dev libwnck-3-dev
09:12 leaeasy joined #deepin
09:13 OT_iux libgtk-3-dev 已经是最新版 (3.18.9-1ubuntu3.1)
09:14 OT_iux no more than 3.19 ...
09:14 leaeasy OT_iux: yakkety
09:14 deepin-bot [felixonmars]:  so it won't work on your system, unfortunately :/
09:16 OT_iux >_<
09:22 OT_iux oh, SamaelChen already fired an issue about this
09:23 OT_iux thank you felixonmars, thank you [somebody]
10:21 talonz joined #deepin
11:09 sbw joined #deepin
11:10 JLye joined #deepin
16:03 ezraholm50 joined #deepin
16:07 hualet joined #deepin
17:12 hualet joined #deepin
17:43 hualet joined #deepin
18:47 hualet joined #deepin
22:25 freecoder hi. i asked this earlier but did not get any response so just reposting the question - <freecoder> [19:14:59] for some reason i cannot update deepin-terminal (https://bpaste.net/show/367ffa250038). i tried switching mirrors (official, georgia, tsinghua) but they did not work. is there any way to download the package via http?

| Channels | #deepin index | Today | | Search | Google Search | Plain-Text | summary